Title
[TEST] Rant & Rave: Incident RCA - 2022/02/01 - Low SMS Response Rate
Information
TITLE: Very Low Response Rate for French Wave 64 SMS Solicitations
DATE, TIME AND DURATION
START TIME: [2022/01/20 – 09:15] RESOLUTION TIME: [2022/02/02 – 10:21] DURATION: 14D 0H 54M
OVERVIEW
Sage reported that after Wave 64 they had only receive a very small amount of feedback from their French SMS solicitations. Only 6 items of feedback had been received versus 113 from the previous wave.
Our L2 team began an investigation of this issue and found no technical issue with the Rant & Rave product that was causing this. Solicitations were successfully leaving the platform and being sent to our provider Open Market.
A ticket was raised with Open Market, and they confirmed that they had sent these messages to their own suppliers without issue and as such raised a ticket with them for confirmation on what might be causing the issue.
After further investigation they confirmed that this had been caused by a routing issue on their end. They routinely will change the routing of their SMS to go via the best route and had done so in this case. Unfortunately, the routing they chose in this instance didn’t support replies to text branded numbers. Recipients either could not reply at all, or their replies could not be received by us.
The routing was reverted, and the issue resolved.
ROOT CAUSE & REMEDIATION
ROOT CAUSE:
Our 3rd party supplier Open Market routed SMS traffic to a supplier which did not support replies to text branded numbers. This resulted in messages being sent but recipients either being unable to reply or their replies not being received by us.
Changing the routing resolved the issue.
REMEDIATION PLAN:
Open Market have reverted the routing back to a trusted supplier and they have confirmed that they will not alter the routing of this traffic in future to ensure there is no issue.
An internal knowledge base article has been created to help Support identify and rectify this issue more quickly in the future if it was to happen again.
RCA ISSUE ID:
877606
Keywords rca, incident, rantandrave
Solution ID
220218112704503
Last Modified Date
02/18/2022 01:25:10 PM
Renew Date
10/09/2024
Status
Published
Author
Taxonomy
- Rant & Rave > RCA-Root Cause Analysis > 2022
Collections
- Rant & Rave Support
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