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TITLJE: Mobile API SMS Delay Outbound Issue - November 2024
DATE, TIME AND DURATION
STARTTIME: November 14th, 2024, at 16:16 GMT
RESiOLUTION TIME: November :ii.4th, 2024, 17:24 GMT
DURATION: 1 HOUR 8 MIN
OVERVIEW
- Starting at 16:16 GMT on Thursday, November 14, 2024,, a disruption occurred in the Mobile API SMS service, leading to dellayed SMS traffic.. The Mobile API engineering team was alerted at 16:30 GMT about a queue of outbound messages (IMTs) speciifically forwarded from the Adestra platform. This issue was rectified by the Mobille AIPI team at 17:24 GMT on the same day - Thursday, November :ii.4th, 2024. As a rnsult, all n,ew messages dispatched from th,at moment were successfully transmitted.
ROOT CAUSE & REMEDIIATION
- ROOT CAUSE:
o The MAPI engineerilng team discovered that a recent update to the service implemented on the morning of 14th lfNovember 202.4 resulted in the consumer''s q1.rnue faillure. This issue arose due to an,update in our core coding language, wh,ich had an inoompatibillity oonflict with a s.eparate service, resulting in the queue consumer failing a few hours after deployment. Since this was a singular version update, we do not anticipate the need for it to be reapplied in the future. Tlhe team promptlly prepared a ifix, which was validated in a staging environment before being implemented as a hotfix to production. As a result o.fthis incident, some messages leaving the Adestra platform experienced a delay of up to 60 minutes.
Keywords Mobile API SMS Delay Outbound Issue – November 2024
Solution ID
250227161939997
Last Modified Date
02/27/2025 04:20:46 PM
Renew Date
02/27/2026
Status
Published
Author
Taxonomy
- Waterfall > RCA-Root Cause Analysis
Collections
- Waterfall Support
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