Rant & Rave: Feedback with Notes added are not showing the Notes icon or 'actions taken' filter on the dashboard
Environment
Rant & Rave
Symptoms
Feedback which was edited to add notes in them, do not show the 'Notes added' icon ,which is an envelope-like image, in their allocated column on the dashboard.
Error (If Applicable)
Resolution Summary
The issue has been raised with our Development team to deploy a fix.
Details
Users with the Notes feature enabled will be able to add notes for a Feedback item via the Message Console on the dashboard.
Once this note is saved, the feedback will be counted in the Filter Console among those with notes added as shown below.
In addition to that, there is a column on the Dashboard, which displays the envelope-like icons for such feedbacks with notes in them, like in the screenshot below.
When either of these is factors above is not reflecting for a feedback item that clearly shows a note in the Message Console, please reach out to Support for further assistance. It would be helpful to confirm first if other colleagues are also replicating the same issue for similar items of feedbacks with notes.
Cause
This issue likely indicates a bug and Support will triage the case before deciding whether a bug ticket can be raised, or if another cause is determined.
Internal Information
Once you receive such a ticket, try to first replicate the issue, then you can also gather additional information like checking the users' access setup, or that of their profile, to verify whether the three correct Notes features below are assigned.
MSG_NOTE
MSG_NOTE_ADD
MESSAGE_RESPONDED_TO
The MESSAGE_RESPONDED_TO feature below in particular is the one responsible for displaying the column with the notes icon.


You should also check similar past tickets such as the example below, to see if there has been a resolution fix issued that you can carry out, or inform the escalation team about.
EXAMPLE: https://upland.zendesk.com/agent/tickets/855065
Afterwards, compile the necessary information and raise an escalation to L2 team to perform the below DB checks in Squirrel.
SELECT * FROM project_XXXX_notes WHERE feedback_id = 'XXXX';
For feedback items where the action_id associated with a note is -1, it does not have the Note icon in the column, but for feedback where the action_id is NULL we can see the note icon.
SELECT action_id, array_agg(DISTINCT(user_id)) FROM project_XXXX_notes GROUP BY 1;
This brings up results for two sets of users:
-Users who add notes and the action_id is set to NULL
-Users who add notes and the action_id is set to -1
The details can then be compiled and a bug ticket raised to the Development team.
Resolution Category
Problem/Incident::Product::Configuration
Keywords
notes icon added edit message console feature raexternalrequest