Title
Mobile Commons: Salesforce Integration - No new records are being pulled
Environment
Symptoms
Error (If Applicable)
Resolution Summary
Details
Cause
Internal Information
Resolution Category
Keywords
salesforce integration new_records raexternalrequest
Mobile Commons: Salesforce Integration - No new records are being pulled
Environment
Mobile Commons
Salesforce out of the box integration
Symptoms
No new profiles/records are being pulled from the salesforce CRM
Error (If Applicable)
Resolution Summary
The URL of the custom report in the configuraiton page on the MC side didn't match the URL of their report on the SF side. Updated the URL on our side and things started to work again.
Details
- Check the synchronization report and confirm that zero records are being pulled.
- Check the API creds and API key and confirm they exist on the configuration page on the MC side. Also, confirm with the client that they are correct.
- Check the custom export URL, make sure:
- It exists and it has the correct export parameters with this format
https://subdomain.my.salesforce.com/CUSOMT_REPORT_ID?isdtp=p1&export=1&enc=UTF-8&xf=csv
- Confirm with the client that the URL is correct and 100% matches the URL of their report on the SF side.
- It exists and it has the correct export parameters with this format
- If all of the above is correct, we may need to create a JIRA ticket to check with the dev. team and dig into to the logs to see if there are any signs, or errors in the logs that would indicate why the sync is failing to pull the records.
Cause
The URL of the custom report in the configuration page on the MC side didn't match the URL of their report on the SF side. Updated the URL on our side and things started to work again.
Internal Information
Resolution Category
Problem/Incident::Third Party::ISP/Network/Integration
Keywords
salesforce integration new_records raexternalrequest