Mobile Commons: Webform sometime subscribe users to an OIP for another webform (Troubleshooting)
Environment
Mobile Commons
Symptoms
We’ve been noticing an issue while testing one of our webforms: https://teen.smokefree.gov/become-smokefree/smokefreeteen-signup.
Sometimes, opt-ins will take us through the correct opt-in path: https://secure.mcommons.com/campaigns/147891/opt_in_paths/312832
But other times, it will take us through the incorrect opt-in path: https://secure.mcommons.com/campaigns/147891/opt_in_paths/214601 Which is linked to this webform https://smokefree.gov/tools-tips/text-programs/quit-for-good/smokefreetxt
We only reference the opt-in path key for the first one, so it is very odd that we’re occasionally going through a different path. Here is a profile that we’ve experienced this with: https://secure.mcommons.com/profiles/550675992?page=1.
Error (If Applicable)
Resolution Summary
I've been testing both webforms extensively and so far, I'm not able to replicate the reported behavior. I'm getting subscribed correctly every time. However, if you are still able to replicate the same behavior recently with your phone number or fresh numbers, please let me know so we can take a deeper look. We may need to have a screen share call where we track/test this process step by step.
Details
Troubleshooting/Response
1- Checked the profiles and I see that there were multiple subscriptions to both opt-in paths.
2- I've done extensive testing on both web forms above and got 100% correct results. I was getting subscribed to the correct opt-in path.
3- Checked the logs in Kibana https://kibana.mcommons.com/ for both reported profiles and noticed that the submission requests made to subscribe both examples/phone numbers to the opt-in path "SFTXT Adult WEB opt-in" is coming from a different IP address than the subscription/submission requests made to subscribe the same numbers to the other OIP "SFTeen Web Opt In", meaning they are coming from different webforms.
Response from the client:
Thank you very much for continuing to investigate this issue. So far, we’ve only been able to reproduce the issue with people who have tested our programs extensively already. Users with less testing data don’t seem to experience the issue. I guess at this point we aren’t going to worry too much about it unless it seems like real users are experiencing similar issues.
I've let them know that If at any point they were able to replicate this and would like to proceed with testing, feel free to reach out and I'm happy to get on a screen share call to better track this down.
Cause
No reproducible
Internal Information
Resolution Category
Problem/Incident::Unable to Reproduce
Keywords
webform web web_opt_in_path raexternalrequest