Title
Mobile Commons: NYC _ Smart campaigns issue
Environment
Symptoms
Error (If Applicable)
Resolution Summary
Details
Cause
Internal Information
Resolution Category
Keywords
NYC smart campaigns incorrect subscription raexternalrequest
Mobile Commons: NYC _ Smart campaigns issue
Environment
- Mobile Commons.
- Smart Campaigns.
- Client: NYC
Symptoms
- NYC reported wrong subscriptions on their smart campaigns that started on 12/13/2023
- After investigating we found that the filtered groups mechanism changed in Dec release and that affected how the profiles get pulled
- The groups mechanism changed from pulling "is exactly" to "contains" in #13312 and that was confirmed in the Jira we created #13573
Error (If Applicable)
Resolution Summary
We updated the custom fields values and changed the groups filters so that the Smart campaign would be pulling the correct profiles.
Details
- We addressed these changes to the client and agreed to change the custom field values used in the smart campaigns to coop with the new changes "They were using letters in their filters so we changed these to words and used the words in the filters"
- We've uploaded a CSV with the values that we agreed to change
- To prevent any wrong opt-ins/outs of the smart campaigns, we created uploaded groups to replace the current filtered groups being used in the smart campaigns before changing the custom fields values.
- We've stopped all of the active messaging schedules on the account based on the client's request
- We've also noticed some wrong custom field types on the account that we communicated back to the client and we changed those types and confirmed it back to the client
- After updating the group filters and the custom field values, the client confirmed that everything is now working as expected and we closed the support ticket
- They also experienced a secondary issue as one of their smart campaign didn't update the subscribers properly, we manually synchronized the campaign by pressing "synchronize smart campaign" from the Campaign Actions and the issue was sorted.
Cause
Internal Information
Zendesk Ticket #1448365
Resolution Category
Problem/Incident::Customization Issue
Keywords
NYC smart campaigns incorrect subscription raexternalrequest