Information
TITLE: Issue with Broadcast Messages Delivery “Scheduled_at error”
DATE, TIME AND DURATION
START TIME: 2025/04/17 _ 09:00 ET RESOLUTION TIME: 2025/04/24 _ 12:30 ET DURATION: 8D 3H 30M
OVERVIEW
- The engineering team noticed that some of the broadcasts sent on the platoform have a high rate of failed messages
ROOT CAUSE & REMEDIATION
- ROOT CAUSE:
- Previously, broadcasts were delayed by several minutes during MT preparation, resulting in late message delivery and a delayed broadcast start time.
- To address this, an enhancement was implemented in the April 16, 2025 release, leveraging the scheduling capability available in our unified mobile messaging platform to send messages at the intended time.
- However, messages were not processed within the expected timeframe in the unified system, which led to some scheduled messages not being processed and therefore not forwarded to mobile carriers.
- On April 22, a feature was enabled on the unified messaging platform to bypass any restrictions related to scheduled messages sent from Mobile Commons.
- However, a defect was found in the newly enabled feature, which caused it to not function as intended. This was fully resolved with a hotfix that was deployed on Thursday, April 24.
- RCA ISSUE ID: MC-15558
Keywords RCA scheduled_at raexternalrequest
Solution ID
250506165857233
Last Modified Date
05/06/2025 05:05:21 PM
Renew Date
05/06/2026
Status
Published
Author
Taxonomy
- Mobile Commons > RCA-Root Cause Analysis
Collections
- UMM Self-Service
- UMM Support
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